Bernhard Häussner

Hello World!

15.10.2008, 19:55

Nachdem ich schon einmal begonnen habe eine Webseite zu basteln, aber dann gemerkt habe, dass sie nicht genügend skalierbar war, habe ich jetzt diese hier gebaut.

Ich benutze jetzt ein Modulares Template-System, das verschiedene Bausteine nach einem XML-Gerüst aufbaut. Die XML-Tags repräsentieren dann die PHP-Bricks, die dann für die Ausgabe zuständig sind.

Der Blog wird dann, entsprechend meinen Interessen, hauptsächlich von Computern, Inernet, (Web-)Development, Kunst, Fahrräder handeln. Viel Spaß beim Lesen!

Kurze URL http://1-co.de/b/1. Post to twitter
« erster Eintrag |

Kommentare

Bernhard H. meint: (#32)
19.10.2008, 23:19

Ok, jetzt dürfte alles klappen:
- Kommentare haben die richtige Zeit, ersetzten Links, Absätze, Permalinks, html-Zeichen machen nichts im Text und im Namen der Person, die Fehlerseite beim auslassen/falsch setzten von Feldern erscheint richtig und die Kommentare lassen sich posten.

Chonologie:

? (5min) Zeitbug gefixt
12:50:47-13:27:53 (37min) Parameterverarbeitung und Überprüfung.
13:27:53-14:28:36 (61min) Herumqualen mit HTML-Entities und Zeichensätzen
? (21min)Testen

21:42:18-21:56:28 (14min) Entwickeln der Fehlermeldungen bei falschen Parametern
? (10min) nl2br und Infrastruktur
? (20min) recherchieren von Hyperlink-Funktion
22:24:47-22:46:57 (22min) Ersetzen von Hyperlinks
? (2min) Anchors für Kommentare

Gesamt: 3h 12min Nur für die Kommentareingabe bzw. kleine Änderungen an der Ausabe. Naja, ich hätte es mir länger vorgestellt.

Bernhard H. meint: (#36)
21.10.2008, 00:16

Grr.. gerade eben habe ich festegtellt, dass immer noch nicht alles auf UTF-8 umgestellt war! Dämlicherweise gibt es im Deutschen ja einen Haufen Umlaute usw. und deshalb muss das passen. Naja, ich habe das ganze durch einen Umlaut in einem Tag entdeckt, dass in der Datenank die Felder zwar auf UTF-8 waren, aber noch das alte encoding ausgegeben haben. Sehr blöd. Denn irgendwie gibt mir die MySQL-Datenbank auch nie UTF-8 Werte. In den XMl-Templates habe ich jetzt auch nochmal explizit UTF-8 angegeben. Ich hoffe jetzt mal, dass auch die Eingebe in die Datenbank richtig funktioniert.

Bernhard H. meint: (#41)
21.10.2008, 00:48

Ok, es war eine schlechte Idee die MySQL-DB auf UTF-8 umstellen zu wollen. Bzw. es ist einfacher die einkommenden Queries und die ausgehenden Werte mit utf8 zu en- bzw. decodieren, sodass man in PHP, XML und (X)HTML stets mit UTF-8 arbeitet, aber in der BD mit dem Standart. Der offizielle MySQL Query Browser hatte auch extrem Probleme mit UTF-8 also habe ich es jetzt in der DB ganz gelassen. Und siehe da: Endlich funktionert alles. Und zwar alles schön da wo es soll. Perfekt. Kuck: äüö߬>






 
Χρόνογραφ
© 2008-2014 by Bernhard Häussner - Impressum - Login
Kurz-Link zu dieser Seite: http://1-co.de/b/1